Timer Queue Off

Timer Queue Off

Issue


TanTrack is reporting that the Timer Queue is OFF (aka Timer Control Manager or TCM).

NOTE:  TanTrack (v3.2.0.4 or greater) Timer Queue Manager (TCM) has built-in features to detect various issues and recover from them when possible.  However, if it can’t fix itself, try the solutions below.

Cause

  1. Using a USB converter on the timer to convert the serial port to a USB port rather than a direct serial to serial connection.
  2. USB Cable or Serial Cable loose or unplugged
  3. Timer Queue (TCM) settings incorrect
  4. Timer (T-Max/FST/Questar) Off


Resolution


Reboot Your PC & Timer

Frequently a simple reboot will resolve your issue.  Start by rebooting the PC ONLY.  Let it start up completely, allowing a few minutes for everything to finish starting up, then start TanTrack.  TanTrack usually will automatically re-launch your timer queue (TCM).  This resolves about 99% of issues.  You can also restart your timer but make sure there are no clients currently using beds as this will reset the beds also.

Serial to USB Converter

If you are using a Serial to USB converter, consider adding a serial port card to your computer. USB Converters are notorious for issues.  While they work fine for many salons, they randomly fail.  They rely on a piece of software to intercept all serial (timer) communication and trick the PC into thinking it is coming from the USB port.  When this software fails, the PC can no longer communicate with your timer.  As your timer is a critical part of your business, eliminating this potential problem area is a very good idea.  This will require installation of a serial card to your exiting PC.  These cards cost around $25 typically and are easily installed by anyone with some basic PC building experience.  These cards typically must be ordered online as they’re not common enough for your local electronic stores such as Best Buy to carry in stock.  

Check Cable Connections

Power
Using your fingers, start from the timer (T-Max/FST/Questar) and identify two cables.  One will be power.  Make sure it is secured tightly and follow it to the wall or outlet.  Make sure its plugged in.  You should see lights or text on the timer itself.  This will tell you that you have power.

Cable to Beds
Using your fingers, find the cable that resembles a phone cable.  Make sure it is plugged in securely.  The timer should show bed status that accurately reflects the status of the beds in your salon.

Cable to PC
Using your fingers, find the cable you did not use for Power or Beds above.  Typically it will be a pretty thick cable.  Often times a white or beige or grey color.  The end attached to the timer will typically have two thumb screws that lock the cable into place.  Follow this cable to the computer.  Along the way you may discover it is connected to yet a 2nd cable or adapter.  This would be the Serial to USB adapter mentioned under possible causes.  Make sure this cable/adapter is securely connected.  Then continue following the cable until it reaches the computer.  If the adapter is being used, you’ll see that the end is USB.  Make sure this cable is plugged into a USB port securely.  If the adapter is not used in your case, make sure the serial end is securely plugged in and the two thumb screws that lock it into the back of the PC are screwed tightly.

Check the Timer Queue (TCM) Settings

The Timer Queue (TCM) is an application that runs in the background ONLY one one PC in your salon.  This is the PC where the timer itself is connected.  This application is responsible for handling all communication between TanTrack and your timer such as starting/stopping beds and reporting bed status.

At the bottom right of your screen, on the bar across the bottom (taskbar) you’ll see an icon that has two people and a green arrow when things are running properly.  If the arrow is red, there is a problem.  Click the icon with your RIGHT mouse button.  A small menu will appear.  From this menu, choose SETTINGS.  A new window will open and you’ll be able to configure your timer.  Select your timer from the list.  If you select NONE, you’ll be able to use TanTrack as if you have a timer but there will be no communication with the timer.  This will allow you to function normally but will require that you set your beds manually from the timer itself.  If you chose None, then you’ll only need to click OK and everything should operate fine.

Otherwise, select your brand of timer such as T-Max.  You’ll then need to tell TanTrack on which port the timer is connected.  Under COM Port, drop down the list and you’ll see your only possible options.  Typically you’ll see COM 1 for example.  Select any port OTHER THAN COM 9 (Credit Card Terminal) and save your settings.  Within about 60 seconds the timer queue off message should go away if you have the correct port selected.  If not, repeat these steps and select any com port you have not previously tried.  Repeat the 60 second wait.

Still Having Issues?


If your timer has no visible lights, is making a weird noise, or displaying an error such as — or N/A, try reaching out to your timer manufacturer.

T-Max:  417-297-0361
CCS Intellitan:  800.445.0624  (NOTE:   CCS Intellitan is just a T-Max with a JK Ergoline faceplate on it - T-Max support *may* be able to assist also.)
FST:  No Longer In Business - HIGHLY recommend switching timers
Questar Database:  No Longer In Business - HIGHLY recommend switching timers.
TanTime:  Pretty much out of the business but you can try to reach them here:  http://www.tantime.com/

Otherwise, reach out to our support team.

TanTrack Technical Support:  972-818-4900







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